18th March 2022

Web dashboard Dashboard is down

Update: everything is now stable. Closing the incident.

--

Update: problem is identified with an overloaded database server. The service is back up but our engineers are still working on it.

--

Dashboard is down, investigating.